OQ error initializing


It's my first post here and unfortunately it's for a problem.

Before explaining my issue i would like to thank every person who made this addon, now that i'm a casual player it simplify the hours i spend on the game.

So, my problem is an OQ error initializing when i try to play, when i connect with a character, this is what happened:

OQ error initializing

realmList: EU

error: Interface\AddOns\oqueue\oqueue.lua:20997 attempt to concatenate a nil value

I'm French and i play on a French realm, precisely a PvP realm (Cho'gall).

But what i discovered is that on a PvE realm, OQ is working fine. No matter the country, no matter the PvE realm, OQ is working.

But no matter the country, no matter the PvP realm, OQ is not working.

I'm not playing on a PvE realm so, i'm in trouble :s

I tried to delete cache: Not working

I tried to delete WTF: Not working

Both: Not working

Launch WoW without the Battle.net launcher: Not working

Try with an account of a friend: Same result, work on PvE realms but not PvP.

Anyways, my sincere thanx for all your hard work and maybe a fix of this problem.

hello, i got the same problem with oqueue, i also play on a french realm, cho'gall, and i up the post to ask if there's a solution to that problem, thanks for reply if there's something i can do to make it work ;)

i've ask a friend from ragnaros (pvp realm ) and he says that oqueue works for him so i don't understand why i can't have it too ^^

G'morning Blazex,

i'm updating oQueue to 3.0.6. please update and verify whether or not you're still having the issue.


unfortunately it didn't change, again same error message :(

what's the error message exactly?

OQ error initializing

realmList: EU

error: Interface\AddOns\oqueue\oqueue.lua:20994 attempt to concatenate a nil value

now it has changed from 20997 to 20994 ^^

what does this return?

/script print(GetRealmName()) ;

i must type it in chat ? when i do it it says "Cho'gall" and when i type oqueue i got oqueue interface but with nothing just the interface

Log in to leave a reply.